Steam API Issues
Incident Report for Tower Unite
Resolved
The Steam API appears to be back online from what we can tell. The AGCs will attempt to go through the backlog and set the stats. We'll continue monitoring the AGCs, and should the issue come back we'll make a new incident. Sorry for the downtime.
Posted Apr 16, 2021 - 15:25 PDT
Update
Steam is still timing out / returning HTTP 500 errors, resulting in EXP, Stats, and Achievement data not being saved. As this has persisted, and more and more requests are coming in for EXP, Stats and Achievements, the system overall is being hammered. We're continuing to monitor our systems at the moment, but we're dependent on Steam for these APIs to be functioning, so this will persist until Valve fixes the issue, which we're sure they're aware of.
Posted Apr 16, 2021 - 14:54 PDT
Update
At this time, it appears only the Steam SetUserStatsForGame API is failing. This API is used for setting EXP and Stat information for accounts. This may lead to stats, exp, and achievements not being saved.
Posted Apr 16, 2021 - 14:35 PDT
Identified
The Steam API is returning HTTP 500 errors, which is leading to issues on the Client AGCs. We're monitoring this situation. This may lead to some progress, such as stats or achievements, not being saved, along with player inventories not loading.
Posted Apr 16, 2021 - 14:26 PDT
This incident affected: AGC.