AGC downtime
Incident Report for Tower Unite
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 19:21 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 15, 2024 - 17:03 PST
Identified
We are currently investigating issues with our backend servers.
Posted Nov 15, 2024 - 17:03 PST
This incident affected: AGC.