Steam Issues
Incident Report for Tower Unite
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 18:38 PST
Update
We have received a response from Steam Support, they are aware of the issue we are having and are looking into it with their developers.

We're continuing our work on moving away from Steam's backend services.
Posted Oct 19, 2021 - 17:39 PDT
Update
We have provided a detailed write up of what happened, and how we are working to fix it. You can read the full write up here: https://forums.pixeltailgames.com/t/weekly-dev-log-for-october-18th-2021/43803
Posted Oct 18, 2021 - 19:55 PDT
Update
We now have support ticket system setup on our Discord. Users who have been effected by this incident can now send in a support ticket and our staff will assist with any account related issues they have (such as achievements, EXP loss, etc.). Please head to our Discord: https://discord.gg/pixeltail and go to the #support channel to create a ticket.

We are still currently monitoring the downtime and working on resolving issues.
Posted Oct 16, 2021 - 08:54 PDT
Update
The issue with users being spammed with multiple milestone items has been mitigated. It may still occur, but not nearly as often nor in the severe number of duplicates being issued.

Users with duplicate milestones can log into https://express.towerunite.com and the website will remove the duplicate items.
Posted Oct 15, 2021 - 15:45 PDT
Update
The issue with units being distributed to users erroneously has been fixed in a recent hotfix.

We're continuing to plan out our move away from Steam for Inventories, EXP, and Achievements. This stage will take some time to complete.
Posted Oct 15, 2021 - 12:16 PDT
Update
The issue where the client was not notified about units and tickets being awarded and redeemed has been fixed in a recent hotfix. We are no longer relying on Steam for this functionality.
Posted Oct 14, 2021 - 19:40 PDT
Identified
There are several issues with Steam at the moment that are affecting Tower Unite.

Units / Tickets: We rely on Steam to notify the game client of updates, such as when to refresh the unit or ticket counter. At the moment, Steam's mechanism for doing so is failing, so the game isn't being notified of updates. We can confirm however, that tickets are being redeemed and saved to the account, and units are being given.

Items / Achievements / EXP: Steam isn't being reliable on this front. Our backend systems are telling Steam to issue out items, achievements, and EXP, and Steam is responding that it has done so. However, this is unreliable, as in some instances, Steam isn't actually issuing out the items, exp or achievements, but it is telling us that it is.

Unexplained Units: We are also aware of units being distributed to users erroneously, and are working on a fix.

We are looking into solutions and are working on a fix.
Posted Oct 14, 2021 - 12:26 PDT
This incident affected: AGC.