AGC down
Incident Report for Tower Unite
Resolved
This incident has been resolved.
Posted Jan 15, 2022 - 18:57 PST
Monitoring
Services seem to be restored and we're monitoring the situation. You might need to restart the game.

We narrowed down the issue to our load balancer. We contacted the hosting provider but they have not yet responded to our support tickets.
Posted Jan 15, 2022 - 18:24 PST
Investigating
The AGC is currently experiencing issues due to our server provider. We are contacting our server provider for further information and to help resolve it.
Posted Jan 15, 2022 - 17:13 PST
This incident affected: AGC.