AGC is down
Incident Report for Tower Unite
Resolved
This issue is now resolved.
Posted Jun 26, 2022 - 04:20 PDT
Identified
The AGC is currently down due to an issue with our server provider. We are currently awaiting a response from our server provider.
Posted Jun 26, 2022 - 03:36 PDT
This incident affected: AGC.